Running experiments in TF >0.12.3 and < 0.13?

Has anyone managed to get the following to work in e.g. 0.12.7 or 0.12.9 ? I get a tf validate error but the repo i’m contributing to is tied to this version…Works fine under 0.12.3 and over 0.13…


terraform {
required_version = “~= 0.12.9”
experiments = [variable_validation]

The variable validation experiment was introduced in Terraform 0.12.20, so it won’t work with 0.12.9.

The version constraint you list above appears to be invalid, but assuming it’s a typo for "~> 0.12.9", that should be satisfied by Terraform 0.12.28. Have you tried upgrading to the latest 0.12 release?

Ah, works! I was stupidly reading the versions wrong