Same configuration as virtualbox vm


I am using wsl2 (windows 10 home) with latest virtualbox 6.1.22 (I run virtualbox bridged, on windows not wsl2 terminal), and so far the connection between wsl2 and virtualbox works correctly.

My configuration is as follows:
2048 Mb (memory)
128 Mb (video card)
bridged interface + nat interface
ubuntu 16.04 mini.iso installed.

I tried to do the same using vagrant with bento/ubuntu-16.04 but it is sluggish (in both wsl2 and windows terminal) and I could never get to the prompt without having issues in ssh / shared folders.

I am using the same configuration in linux and works seamlessly. The reason I am using wsl2 is because I have a very modified ansible script and deployment tools that require linux to operate in order to deploy to virtualbox.

hyper-v issues are somehow set aside with just running virtualbox and wsl2 at the moment. It’s on the vagrant middleware that I get errors (and I also tried the wsl2 plugin).

Any ideas? Anything to add in order to see any errors?