Schema: Incompatible API version with plugin. Plugin version: 4, Client versions: [5]

When I am working with my custom provider with terraform version 0.11.0. I am don’t have any issues. When I am trying to update my terraform code to 0.13.0 . I am getting below error.

Error: Failed to instantiate provider “custom_provider” to obtain schema: Incompatible API version with plugin. Plugin version: 4, Client versions: [5]

My custom provider is written on 0.11.0 terraform version . I have not upgraded my custom provider to 0.13.0 .
Kindly suggest me how to fix this issue.

Appreciate your support!.


Hi @umabosani,

The provider plugin protocol changed in Terraform 0.12 to support the various new features in that release. You must therefore build a new version of your custom provider to use it with Terraform v0.12.0 or later.

The Terraform SDK team wrote a guide to upgrading existing providers for Terraform v0.12 compatibility, which should be sufficient to make your provider work correctly with Terraform v0.11, v0.12, and v0.13.

That guide also includes a note about switching to the standalone SDK after you’ve completed your initial upgrade, but I notice that the link in the text is incorrect at the time of writing. The guide it intends to link to is Switching to the standalone SDK. That’s optional if you don’t intend to do any further development of your provider that might benefit from newer SDK features, but since there is an automatic migration step for this (once you’ve completed the initial upgrade in the first guide) it may be worth just trying it anyway.

Please note also that the end-user-oriented upgrade guide for Terraform 0.13 assumes that you have completed an upgrade to 0.12 first. If you try to move directly from Terraform 0.11 to 0.13 then you might encounter problems that the upgrade guides don’t anticipate.

@apparentlymart Awesome!. It worked.

Thanks for the quick response!.