SDK forces the usage of namespace

When I run golang in kubernetes and use the golang sdk to register a service, it forces the usage of “ns” in the query, which is a Consul Enterprise feature. This results in the call failing : Unexpected response code: 400 (Bad request: Invalid query parameter: “ns” - Namespaces are a Consul Enterprise feature) . The Namespace in Config is set automatically when I’m not setting it, but I would like it to not be set so that ns=… doesn’t appear in the query url.
When run locally there is no issue, the issue appears only when executing the code from inside kubernetes.
Has anyone ever experienced the same issue ?