Ssh agent forwarding


I am using vagrant from Ubuntu. I try to get done an ssh agent forwarding to my windows (guest) virtual box machine. I configure it like this:

Vagrant.configure("2") do |config|

  config.winrm.max_tries = 300 # default is 20
  config.winrm.retry_delay = 2

  config.ssh.private_key_path = "~/.ssh/bsc_laptop"
  config.ssh.forward_agent = true = "gusztavvargadr/windows-11"
  config.vm.communicator = "winrm"
  config.vm.hostname = "w11" "public_network", bridge: "$wifi_name" "public_network", bridge: "$ethernet_name"

  config.vm.provider "virtualbox" do |vb|
      vb.memory = "9000"
      vb.cpus = "4"
      vb.gui = true = "my_w11"
      vb.customize ["modifyvm", :id, "--accelerate3d", "on"]
      vb.customize ['modifyvm', :id, '--clipboard', 'bidirectional']
      vb.customize ["modifyvm", :id, "--draganddrop", "bidirectional"]
      vb.customize ["modifyvm", :id, "--cpuexecutioncap", "60"]
      vb.customize ["modifyvm", :id, "--usb", "on"]

  config.vm.provision "shell", inline: <<-SHELL
    powershell -Command "Set-WinUserLanguageList es-ES -Force"

  if Vagrant.has_plugin?("vagrant-vbguest") then
    config.vbguest.auto_update = false

But when I try to use it in the virtual machine I only get:
Powershell → ssh-add -l
Error connecting to agent: No such file or directory

I don’t see anything at the debug log related to this. That makes me think is not trying to being achieved. Am I missing something? I don’t report this as a debug, because I’ve seen many resolved things about this in the past, already solved, and almost always about the provisioning.

And this:

makes me thing this is an already solved issue.

So, what I am doing wrong?