SSH certificates: permission denied error: allowed_users "*" doesn't work

I’ve been learning how to use ssh certificates with vault for a few weeks, but had ssh issues unless I use the default user name.

According to the docs it is an ssh bug, but what can we do to fix it? Predefining a list of principles isn’t an option since new users could require access at any time.