Stop Packer from generating SSH key when using ssh_password

I am using ssh_password to provide a plain test password for access to my GCE Instance during my Packer build. Packer is still generating an ephemeral SSH key and adding it to instance metadata. I don’t want this to happen as adding SSH keys to instance metadata cause the Google guest agent to configure a number of settings on the guest instance that I want to avoid.

I have a workaround to create a dummy SSH key and provide it using the ssh_private_key_file attribute which does stop Packer from generating an SSH key and adding it to metadata.

Wondering if there’s a better way?