Tar archive contains too many files: 4097 > 4096

While upgrading a server, one of my jobs had to migrate to another server. It never came back up to due to this error.

client.alloc_runner.task_runner: prestart failed: alloc_id=* task=humhub error="prestart hook \"artifacts\" failed: failed to download artifact \"https://download.humhub.com/downloads/install/humhub-1.13.2.tar.gz\": getter subprocess failed: exit status 1"
client.artifact: sub-process: OUTPUT="failed to download artifact: tar archive contains too many files: 4097 > 4096"

Is there potentially some limit in place here that can be extended? This same file worked fine before though, and I’m using the md5 checksum, so I don’t think the file changed.

Hi @nathanpalmer, the Nomad v1.5.0 release now sets default limits for the number of files extracted from an archive (and a total size limit on all files) - as a measure against fork bombs. You can configure (or disable) either of these limits in client config:

1.5.0 release notes

Thank you! Adding the client configuration for artifact solved this problem.