Terraform version and AWS Provider versions compatibility?

Hello,
We are using terraform to provision our resources on AWS and right now we want to use Timestream Database in order to achieve our business requirements. I see that timestream database and tables are available as of AWS Provider 3.40.0, but i can’t see anywhere what is the minimum supported Terraform version for that provider.
I am asking this because in our company we are using terraform version 0.12 and i am not sure if that is compatibile with AWS Provider 3.40.0.
Is there a table somewhere that shows which providers are supported by which terraform version?
Best Regards,
Alex