The plugin.(*GRPCProvider).UpgradeResourceState request was cancelled

Hi!

On our project we are using Terraform (1.1.7) with AzureRM (v3.0.2) provider on an Azure DevOps pipeline and it was working until Thursday (2022.03.31) without any issues. However on Thursday during the execution of terraform plan command the pipeline started to throw errors:


We are only having this issue for one of our environments, the other environments with the same terraform code is working properly. I’ve also tried to remove the .tfstate file from our Azure blob storage and the plan phase was successful again (it wanted to re-create the whole environment), so my assumption was something is wrong with the .tfstate file.

Can you please help what can be the issue? What else should I try?

Thanks!

Hi lpetighost,

Did this ever get resolved as I am having the same issue.
Other environments seems to be fine, and other engineers can run the same code, but anytime I run a “terraform plan”, I get these errors.
Tried all suggestions I’ve come across, still persists.

Hi both!

This seems to be an Azure provider bug and so I’ve moved this topic into the Azure provider’s category in the hope of making it more visible to those who are more familiar with that provider.

With that said though, any time a provider crashes with a “panic” like this is always a bug in the provider, since providers are supposed to return normal error messages when given invalid input. Therefore I would suggest also checking if this problem is already tracked as an issue in the provider’s own GitHub repository and opening a new one if not. You can always find the GitHub repository for a particular provider from its listing page in Terraform Registry.

I was able to resolve this issue by replacing my terraform.exe file from 386 to Amd64.
Terraform init
Terraform plan
Hope this helps someone.

1 Like

This solved it for me!
Never thought that this could be the problem :man_facepalming:
Thanks for this idea!