Unable to use ami_org_arns with amazon-ebs builder

I’m using latest Packer (1.7.8) and amazon-ebs builder.
I’m trying to use ami_org_arns attribute Amazon EBS - Builders | Packer by HashiCorp instead of the older one ami_users Amazon EBS - Builders | Packer by HashiCorp

but getting the following error

Error: Failed to prepare build: "amazon-ebs"

1 error occurred:
        * unknown configuration key: '"ami_org_arns"'

Does anyone know what is the issue here? Thanks!

Are you using the latest builder? Looks like it is in there: Search · ami_org_arns · GitHub
Although I don’t think you can replace ami_users with ami_org_arns. ami_org_arns is marked as ‘not required’.

How to “use” the latest builder? I’m not specifying any version of the builder, just the Packer binary I’m using.
An yes, even by the documentation as I’ve linked, that parameter is supported.

Both ami_users and ami_org_arns are optional parameters. I’m switching on using them to simplify the sharing of my AMIs
This is a new API feature on AWS side Amazon EC2 now supports sharing Amazon Machine Images across AWS Organizations and Organizational Units

My builders sections looks something like this

  "builders": [
      "type": "amazon-ebs",
      "ami_description": "LVM-partitioned minimal CentOS 7",
      "ami_name": "{{ user `image_identifier` }}-{{ timestamp }}.x86_64-gp2",
      "ami_regions": "{{ user `ami_regions` }}",
      "ami_org_arns": "{{ user `organizations` }}",
      "encrypt_boot": true,
      "kms_key_id": "alias/ib-ebs"

It worked fine so far with the ami_users option and still does

I’m only starting with packer myself, but if I understood the init parameters, even if you don’t specify a parameter, it won’t pull a new version down if it has a version already stored. The “specify” of version is used when you run the init command.

The last version of the ebs builder is 1.0.6 and it was released 12 days ago.

True, but I was using .json configuration so far and without version constraints (so latest would be fetched automatically)
Plus, there is still no need for those core plugins to constrain them as stated in the link you provided

You don't need packer init for this, as of v1.7.0. But it's a good idea to get familiar with the required_plugins block anyway, because we are going to start splitting popular HashiCorp-maintained components like the amazon-ebs builder out of the core into their own multi-component plugins. 

But yes, I agree with you and to stay future proof/valid, I’ve now migrated to latest HCL configuration and added constraints.
After init, 1.0.6 is pulled and used but still experiencing the issue.

Found this, looks like this is an issue AMI Sharing to AWS Organizations: Unsupported Argument · Issue #171 · hashicorp/packer-plugin-amazon · GitHub and I’m not the only one experiencing it with the latest builder

Fix that is working AMI Sharing to AWS Organizations: Unsupported Argument · Issue #171 · hashicorp/packer-plugin-amazon · GitHub + converting from legacy to HCL syntax is needed