Using plugin dependencies that require Ruby 2.5

It looks like the async-io gem (which is a dependency of the vagrant-dns plugin) now requires Ruby 2.5 or higher so it won’t install witrh the embedded Ruby version (2.4.9). How can I select a more modern Ruby version?

You could try rvm (

Is rvm really needed when I just want it to use my existing system Ruby version (2.6 on macOS Catalina)? In either case I would still need to point Vagrant to use the correct version AFAIK.

My mistake. I thought with “embedded” you would mean your system. :wink:

Hey there @bitfactory-henno-sch,

Good news – the upcoming Vagrant release (2.2.8) will ship with Ruby 2.6. Thanks for letting us know about this issue!