Vagrant, VMWare Workstation 16 Pro, Unable to constraint allocated disk space

I have been using Vagrant with first VirtualBox and then VMWare plugin for sometime and getting a hang of it. However, I noticed that the primary disk Vagrant allocates using the entire 128GB disk unlike when I create VM from VMWare Workstation GUI where I typically set to only 20GB for now (non-production/research env.). I have googled and tried everything that I saw regarding disk size allocation, etc. but no avail. It is quite frustrating and also noticed vmware and virtualbox have different options/behavior. I have tried the following which did not work.

node.vm.disk :disk, name: “os”, size: "20GB, primary: true

Also, I cannot create a another storage device like /dev/sda which I was able to using workstation and virtualbox user interfaces and it shows up inside the VM using Vagrantfile. Is this something a limitation of Vagrant or am I dont something wrong in the Vagrant file. I was doing the second device for GlusterFS storage to keep it separate from OS disk.

Thanks for any help you can provide.

BTW, I added the flag


Hmmm, could you try updating your version of the vmware plugin.

vagrant plugin update vagrant-vmware-desktop