Vault 1.9.1 worked great forever but suddenly won't start ui

running vault 1.9.1 for a while.

suddenly stopped allowing us to run the UI?

certificate is not expired.
binary is unchanged.

can’t find anything anywhere describing what might be occurring.

closest thing was people on homebrew w/same error, but running hashicorp vault github binary on alpine linux. same config for over a year. the server seems to start, it just won’t open UI. we wrote some docs to explain how to use it but they don’t work w/out the ui.

(please don’t respond telling us to use CLI, appreciate that thx)

What does “suddenly stopped allowing us to run the UI?” mean?

Put the server in debug mode and see what the log says when trying to access it.

sorry, when we go to the vault ui (eg /ui/vault), instead of seeing the normal login, we see message:

“Vault UI is not available in this binary.”

There is no error in console.

We’ve been using vault UI for some time now through this binary, so I’m a little confused how it could just shutoff when it’s same exe and config.

Running in test mode is a good idea to try to get more information.

ok didn’t figure out why this suddenlly happened but did find a solution.

just updated the binary download url and forced a new download, restarted and message went away.

Most likely Vault was restarted without the

ui = true

in the config file. That’s how you get that message.

while it’s true not enabling the ui could cause that message, not issue here. our config is in version control and ‘ui = true’ has not changed since the first checkin. also restarting it did not solve issue.

this message can also be caused by running a build w/out ui support compiled in, but also was not case as we’ve used this binary w/UI for months.

thinking our source binary got corrupted somehow is most likely culprit, since re-downloading fixed issued.

i’ve looked for a way to mark this issue as ‘resolved’, but i can’t find one.

I’ll just say, this issue was SOLVED / RESOLVED: re-downloaded 1.9.1 release.