Vault get secret API call returns empty result

When I try to get a secret via vault api call like below,
its giving me 404 error.
Instead if I remove ‘data’ from the url like below,
I am able to get the response with the secret values.

Is there any config missing at vault level which is not allowing me to get the response with the first url?

Seems like you’re using KV Secrets Engine - Version 1 (doc) and the ?version=v1 is just being ignored since that backend does not support versioning.

You can check the engine version with

curl \
    --header "X-Vault-Token: ..." \


      "options": {
        "version": "2"

Please note that in your description the secret name is missing in the URL.

Thanks for the quick response.
Yes, its the v1 secret engine.