Vault ssh signing 400 error code

Hello Hashicorp Community,

I am just dipping my toes into Vault. Currently, I am attempting to write a signing key pair to a ssh secret endpoint, with the goal of signing data with this key. No matter what I do I get a 400 error code message back from the server.


The documents are extremely sparse with regards to writing the signing key:

I can’t figure out if I am supposed to put the filepath in here or the actual data itself. I’ve tried just about everything:

The key I generated to do the signing was made via the following command:
ssh-keygen -t rsa

Tried to set this from the web UI and it has been spinning saying its doing something for 10 minutes:

You should probably add an error message to the UI instead of spinning out on a error code:

Resolved this through the UI console by supplying a non encrypted key. Two issues here, one is that the UI doesn’t tell you when there is an error parsing the key. Second is that the command prompt tells you nothing when there is an error. Just gives you back the generic error shown above. I believe there is some way to turn on debug messages on from the console but not sure how.