Why is Vagrant in Ubuntu (20.04) Docker container on Windows looking for PowerShell?

I am taking some training where all of the examples are in Ubuntu, but I am on Windows.

So I thought I would install an Ubuntu 20.04 Docker container, and do my work there. That went well.

The examples also require VirtualBox and Vagrant to be installed in Ubuntu, so I installed those in my Ubuntu container, and again all is well.

However, when I run vagrant up from my Ubuntu docker container (running in a Windows 10 PowerShell) I am getting an error:

Failed to locate the PowerShell executable on the available PATH. Please ensure PowerShell is installed and available on the local PATH, then run the command again.

Here is my path:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/powershell/

I have installed PowerShell for Ubuntu 20.04 in /opt/powershell/ following the instructions here: Installing PowerShell on Linux - PowerShell | Microsoft Docs
The installation was successful, and I am able to launch a new PowerShell, but the same error message comes.

I have hypervisor running, so I tried vagrant up --provider hyperv just for the fun of it, but it was essentially the same error ( a bit more wordy is all)

Is Vagrant supported in this fashion, running in an Ubuntu Docker container on Windows in PowerShell?

What do I need to do to get Vagrant to launch this instance?