Working JSON breaks HCL2 upgrade - unknown builder type & builder missing 'type'

With the release of 1.7.0 we took took a first run at converting our JSON definitions, unfortunately we made no progress and reported our problem in Working JSON breaks after HCL2 upgrade - Error: Variables not allowed.

It looked like the issue was fixed in 1.7.1 and now that 1.7.2 is out we’ve tried taking another run. This time it seems we’ve hit an issue of trying to migrate JSON to HCL2 and move from Packer version < 1.7.0 to Packer 1.7.2

$ packer hcl2_upgrade ubuntu-18.04-chef0-development-amd64-commented.json 
unknown builder type: "upcloud"

We’d settle for hand editing a first draft from the conversion tool if it meant it did the bulk of the conversion work - which is error prone.
So we tried removing the offensive types - we get a more verbose complaint, but still nothing is produced:

$ packer hcl2_upgrade ubuntu-18.04-chef0-development-amd64-commented.json 

Failed to parse file as legacy JSON template: if you are using an HCL template, check 
your file extensions; they should be either *.pkr.hcl or *.pkr.json; see the docs for more 

Original error: 2 errors occurred:
    * builder 5: missing 'type'
    * builder 6: missing 'type'

How are people migrating, esp given some of these definition files are non-trivial and high risk changes.

Appreciate any thoughts.

Can you open an issue for this new problem on Issues · hashicorp/packer · GitHub? We want to take a look but will need a template example that reproduces the failure.

Thanks for looking into this: