Your IP is issuing too many concurrent connections, please rate limit your calls

When i am using the REST API this error pops up. Is there any way to fix it?

Consul 1.9.0

Hi @JayChandler,

This indicates your client is hitting the maximum number of allowed HTTP connections. You can increase this per-client limit using the limits.http_max_conns_per_client configuration option. For example:

# config.hcl
limits {
  http_max_conns_per_client = 400
}

Been banging my head against the monitor with this issue for the past 3 days. I have a lot of services launching at the same time and 80% of them were failing with “NOT FOUND Consul KV” and other wierd stuff, but the data was there. Thanks for this ! PS : Hasicorp documentations is chaotic.

Hi Blake,
pls help us on how to configure http_max_conns_per_client in dockerized consul container image.

Thanks,
R Ramarajan