Accessing Vault dev server UI gives a blank screen

After starting Vault server in dev mode, when trying to access http://127.0.0.1:8200 get a blank screen

  • behavior is same in Chrome, Edge and Firefox

  • In Chrome (using developer tools), see the following error

“Refused to execute script from ‘http://127.0.0.1:8200/ui/sw-registration-1b862bc1e33e4a8a41781d56c3469209.js’ because its MIME type (‘text/plain’) is not executable, and strict MIME type checking is enabled.”

Any help or guidance is appreciated
SG

There are various threads in this forum that are related to this. It’s a strict mime check issue.

There is a link in this discussion:

@Aram,
Thank you for pointing me to the solution referred to in that post. I tried all of the suggestions there, but have not been successful.
Really appreciate your taking time to respond.

I am still continuing to research a fix for the issue
Any help/recommendation is appreciated.

Hello
Just wanted to give an update on the issue. My issue has been resolved. Here is what I had to do

I had to change the content type from text/plain to application/javascript at 2 locations in the windows registry. (screenshot included)

  1. HKEY_CLASSES_ROOT.js
  2. HKEY_LOCAL_MACHINE\SOFTWARE\Classes.js

Steps to make the change
Part1

  1. Open the Windows Registry Editor i.e Win + R > regedit
  2. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.js
  3. Check to if the Content Type is application/javascript or not (it may say text/plain)
  4. If not, then change it to application/javascript

Part2

  1. Navigate to HKEY_CLASSES_ROOT\.js
  2. Check to if the Content Type is application/javascript or not (it may say text/plain)
  3. If not, then change it to application/javascript and try again

NOTE: If the Content Type key is not present under the .js folder,

  • Right click on the folder → New–>Key and add the Content Type Key
  • Then “Modify” the key to add the value of "application/javascript