AWS Provider 2.7.0 docs gone from Google search

All of a sudden, starting roughly yesterday (2020-08-06), I’m unable to use Google to search for Terraform resource documentation for the AWS provider. For example, I used to be able to Google for “aws_workspaces_workspace” (or any other resource), and the #1 search result would be a link to the documentation I was after (e.g.

Now, the exact same search returns GitHub issues, links to this discussion forum, and third-party results, but the actual documentation is nowhere to be found.

I suspect what has happened is that Terraform has blocked robots from indexing the old AWS provider version (2.70) and initiated a Google re-indexing of the site, effectively purging those search results from Google. I’m sure Google is now indexing the new (3.0) version of the provider, and that some time from now they will rise in PageRank and show up as the #1 result, but for now, it’s effectively impossible to Google search for any AWS resource provider documentation; it simply doesn’t show up in the first few pages of results.

This is making it pretty hard to quickly find valuable information. I’ve bookmarked the table of contents for the documentation so that I can manually navigate to the pages I need, but that’s really cramping my style.

If my speculation about what’s happened is true, in the future please consider allowing the new versions of documentation to naturally percolate to the top of the search results, rather than agressively expunging the old versions. Last month’s documentation is far better than no documentation at all.

1 Like

Hi @fweep

I am having the same issue, had to include terraform in the query, it will probably improve in a few weeks.

There is another problem, if you are looking at the latest documentation for any resource and want to see a previous release documentation for the same result, as soon as you change the release selector it goes to that release home page, so you loose the resource and if you use the search function it always uses the latest release.

Yes, I’ve been struggling with the same problem when I change the version in the documentation dropdown.

Regarding Google, I’ve tried including “terraform” in the query, but it’s not helping much with the searching. I quote both terms, like so:

“aws_workspaces_workspace” “terraform”

…and get no decent results.

To be clear, I’m not expecting any specific action from this; I too assume it would improve over time. If my assumptions about why this is happening are correct, though, I hope that some change can be made to prevent the search results from vanishing for days/weeks after every documentation version bump.