AWS transit gateway can't be found

Hi all, I have run in to a very weird problem with my transit gateway (TGW) set up. When running a plan I hit the following error:

Error: reading EC2 Transit Gateway (tgw-82u3e0823e09): couldn't find resource
│   with aws_ec2_transit_gateway_vpc_attachment.acc2,
│   on line 36, in resource "aws_ec2_transit_gateway_vpc_attachment" "acc2":
│   36: resource "aws_ec2_transit_gateway_vpc_attachment" "acc2" {

I’ve got a TGW in account 1 (acc1) and I’ve got a VPC attachment in account 2 (acc2). This worked at first, no problems connecting the 2 accounts. However once introducing a vpn set up in acc1 I get this error now.

For some reason it is trying to find the TGW in acc2 and fails because it’s not there. I really don’t understand why it’s looking in acc2, especially because it worked before adding tf files for the vpn set up so I would greatly appreciate any help with this.

I’m currently using aws provider v4.59.0 and tf v1.4.0

Did you ever find an answer for this issue?

I’m getting the same thing when I do a plan (referencing outputs or static values) for the transit gateway id.