Checkpoint timeout

Hi All,

I am using an azure devops agent (Ubuntu 22.04 LTS) to create Checkpoint firewall rules via Terraform. I am using the classic editor without yaml for the tasks. Terraform version is 1.7.4.

Everything is going fine until I want to create a bunch of rules (approx. 200) then the apply fails with following error Post “https://***:443/web_api/add-access-rule”: context deadline exceeded (Client.Timeout exceeded while awaiting headers). I figured it out it causes because the terraform did not get response from the Checkpoint under 10 seconds for a simple rule creation so it assumes it is failed, but the rule in the Checkpoint has been created.

I have found an environment variable TF_REGISTRY_CLIENT_TIMEOUT which is responsible for the timeout, it’s value is 10. I tried to increase it in the terraform apply step, in the parameters file, in the main, but i couldn’t succeeded.

Could anyone help me how to increase the value of the TF_REGISTRY_CLIENT_TIMEOUT variable? Or am I completely wrong?

Thanks!

you may want to try this:

Hi @Ombi657,

I’m not familiar with the service you are trying to configure, but one thing I want to point out is that TF_REGISTRY_CLIENT_TIMEOUT should be relevant only for requests to a Terraform provider or module registry, such as registry.terraform.io. Terraform interacts with registries only during terraform init, so I don’t think that environment variable should be relevant to the problem you’ve encountered.