Constraint "${attr.consul.version} semver >= 1.8.0"

1 Like

Hi @aliegrsp,

The error indicates Nomad is not correctly fingerprinting Consul or that it cannot find the Consul API. Do you have any logs available from the Nomad agent?

Thanks,
jrasell and the Nomad team

Hey @jrasell ,

I have the same error, but I’m not using Consul. My setup is very simpl/straightforward I know Nomad server IP address beforehand:


cat /etc/nomad.d/nomad.hcl
data_dir = "/var/nomad"
bind_addr = "0.0.0.0"

# Enable the client
client {
  enabled = true
  servers = ["192.168.100.254"]
}

# Disable the server
server {
  enabled = false
}

# Match the datacenter and region of the server
datacenter = "dc1"
region = "global"