Consul envoy configuration NOT getting updated with new request timeout, connection timeout

The aim of the application in a service mesh is to perform actions which will take upto 40 seconds. The default request timeout in consul mesh envoy is 15 seconds only. I have tried updating the envoy settings as mentioned in this link.

I have tried with the said settings in my kubernetes cluster with global proxy-defaults and service router. But none of them are showing any effect.

helm chart version: 0.45
Consul version: 1.12.2

Please suggest any methods or configurations to update envoy proxy request timeout.

1 Like