Consul HCS Helm Deployment - Pod error

I was working on deploying the HCS service on Azure previously and was successful. The next step was to add my AKS cluster to the HashiCorp Consul Service I provisioned and to that I followed this video on youtube. I was able to follow all the steps until the one where he adds the Bootstrap Token to the ACL, I have no option to add tokens, I can only create them.

Another issue I ran into was the pods not being in ready state:

When I described the pod, I got a readiness probe failed error.

When I looked into the logs I got the following for all 3 consul pods:

My helm deployment command was as follows:

helm install consul hashicorp/consul -f config.yaml --set server.affinity=""

My config file: (modified hosts, join and k8sAuthMethodHost for privacy reasons)

  enabled: false
  name: consul
  datacenter: dc1
    manageSystemACLs: true
      secretName: aksconsul-bootstrap-token
      secretKey: token
    secretName: aksconsul-hcs
    secretKey: gossipEncryptionKey
    enabled: true
    enableAutoEncrypt: true
      secretName: aksconsul-hcs
      secretKey: caCert
  enabled: true
  hosts: ['']
  httpsPort: 443
  useSystemRoots: true
  k8sAuthMethodHost: https://cluster-link:443
  enabled: true
  # If you are using Kubenet in your AKS cluster (the default network),
  # uncomment the line below.
  exposeGossipPorts: true
  join: ['']
  enabled: true

Have you been following this tutorial? Connect an Azure Kubernetes Service (AKS) cluster to HCP on Azure | Consul - HashiCorp Learn


I did follow that tutorial just now, however I ran into the same error as seen below:

Issue Resolved: I re created my config.yaml and found out that a couple of the values were incorrect that caused the above errors. I was experiementing with the config earlier and did not revert some values to their original. :grinning_face_with_smiling_eyes:

1 Like

Great to hear it! _____