Consul on AKS Tutorial - No helm-consul-values.yaml file

Hi, I’m new to consul I could be missing something here but following the Consul on AKS tutorial, one of the steps to deploy is to use the command:
helm install azure hashicorp/consul -f helm-consul-values.yaml
But it seems to be missing the “helm-consul-values.yaml” file.

I had followed the previous step to download the relevant files:
git clone

But going to the git link also doesn’t show the “helm-consul-values.yaml” file.

Am I missing something?

Hi @vtphan24 the file name has changed to config.yaml try that instead. Thanks for sharing, we’ll get the tutorial updated.

Thanks @karl-cardenas-coding, that worked. By the way, if you’re going to update it, you might want to update a couple of other things while at it.

  1. In the “demo-consul-101/k8s/terraform/azure/01-create-aks-cluster/ file”, the command below should probably include the --over-write flag?
    az aks get-credentials --resource-group demo-rg --name demo-aks

Without the flag, deploying for the first time is fine. But if you delete everything (AKS cluster, demo-rg, etc) and re-deploy the AKS cluster, it will fail with error message:
A different object named demo-rg already exists in clusters

  1. In the Deploy Microservices part of the tutorial, it says the counting service will deploy as a LoadBalancer. But the dashboard-service.yaml file has the LB service commented out. So user need to remove the comment if they want it consistent with the tutorial steps.

This is currently being worked on. As well with the other issue you opened up.

1 Like

@vtphan24 the tutorial has been updated and the issues you raised have been addressed. Thanks again for making us aware of these.

This issue has been resolved in the updated version of the tutorial.

Very cool, thank you for the update!