Consul setup on EKS for mimir or cortex TSDB

Hi I am getting error when run consul in EKS.

error detail :kubectl logs consul-connect-injector-75bbb95d86-7sfgn -n consul
2023-09-16T09:02:15.142Z [INFO] consul-server-connection-manager: trying to connect to a Consul server
2023-09-16T09:02:15.243Z [ERROR] consul-server-connection-manager: connection error: error=“failed to discover Consul server addresses: failed to resolve DNS name: consul-server.consul.svc: lookup consul-server.consul.svc on no such host”

[cloudshell-user@ip-10-2-62-195 ~]$ kubectl get po -n consul
consul-connect-injector-75bbb95d86-7sfgn 0/1 CrashLoopBackOff 6 (8s ago) 8m46s
consul-server-0 0/1 Pending 0 8m46s
consul-server-1 0/1 Pending 0 8m46s
consul-server-2 0/1 Pending 0 8m46s
consul-server-acl-init-n6n4f 1/1 Running 0 8m46s
consul-webhook-cert-manager-f4988cf75-hrzfm 1/1 Running 0 8m46s

DownwardAPI: true
QoS Class: Guaranteed
Tolerations: op=Exists for 300s op=Exists for 300s
Type Reason Age From Message

Warning FailedScheduling 4m49s default-scheduler running PreBind plugin “VolumeBinding”: binding volumes: timed out waiting for the condition

Hi @prashantnitt07,

Welcome to the HashiCorp Forums!

Can you verify whether your EKS cluster has the EBS-CSI addon enabled? This is a requirement to install Consul as the Server Agent pods need persistent volumes to store data.

From the output, the server pods are in pending state, and it could be because of volume issues.

This KB has more details that might help: Troubleshoot Some Common Amazon EKS issues while installing Consul – HashiCorp Help Center

reslove issues with below step , sc , pv for 0,1,2 consul server1 2 3