Corrupt package files for buster in apt-repository

(category not accurate for the issue, I chose this because it’s the package I’m trying to fetch).

It seems to me like this file is corrupt/broken.

Running apt update causes apt to show the following error.

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/apt.releases.hashicorp.com_dists_buster_main_binary-amd64_Packages
E: The package lists or status file could not be parsed or opened.

I’m using the following in /etc/apt/sources.list.d/hashicorp.list.

deb [arch=amd64] buster main

Does anyone have the same problem? Should I submit an issue on GitHub?

1 Like


We encounter the same error now.
In fact, it’s not the first time there’s an issue with debian package: Packages file seems corrupt for Debian Stretch - #2 by kpenfound last issue.
@kpenfound can you help us this time?


1 Like

There’s also a Github issue on it: Hashicorp Buster APT package - Problem with MergeList /var/lib/apt/lists/apt.releases.hashicorp.com_dists_buster_main_binary-amd64_Packages.lz4 · Issue #12181 · hashicorp/consul · GitHub

Hi all,

Thanks for the reports! This is resolved as of ~1 hour ago. We do have checks to prevent this kind of thing from happening, but it appears something got through in this case and we need to improve the validation for the future.


I also see same issue with Vault / Ubuntu Xenial on

There’s a section missing the Package: too:

Filename: pool/amd64/main/vault_1.9.3_amd64.deb
SHA1: b7c932863208a5c17f1aa02026315216d494e398
SHA256: 566747eaa3697f9b25cb471d10e6d9832c382956dfd84a74630ac37f2ad2da28
Size: 69357190

Can you please have a look at this one also? :slight_smile:

Hi @bjorn , thanks for reporting this. This should be resolved as of ~5 hours ago. To add some transparency, this is caused by a bug with the tool we use to generate the repo metadata, and we’re working on solutions to prevent this from happening. Apologies again for the inconvenience!


Hi Kyle,

Thanks, but it’s still a problem (or it happned again) (

Filename: pool/amd64/main/consul-k8s_0.39.0_amd64.deb
SHA1: c1472db558d565e9325e85a55565a6ddfeb14acf
SHA256: f29d92ca16e35b048eb37239036c934ed9b5c98bd6d6940589827617f4b0dc5a
Size: 25041304

Is it possible for you to re-generate it again, please? :slight_smile:

1 Like

Hello everyone.
Today I got the same issue. Does anyone know what I should do with this?

E: Failed to fetch  File has unexpected size (55168 != 54973). Mirror sync in progress? [IP: 443]

Same issue here, except with IPv6 addresses. Can’t install Vault via apt at the moment.

Same here, got the following error when doing “sudo apt update”
E: Failed to fetch File has unexpected size (55168 != 54973). Mirror sync in progress? [IP: 443]


Same here, any luck? it could be an issue with their servers running behind amazon. I’m not able to apt-get update since 3 days ago.

Looks like it is good to go once more. Thank you to whoever fixed it!

Hey all, I think this problem is back again. Started yesterday.

Get:11 jammy/main i386 Packages [31.3 kB]       
Err:11 jammy/main i386 Packages                 
  File has unexpected size (31295 != 31290). Mirror sync in progress? [IP: 443]
  Hashes of expected file:
   - Filesize:31290 [weak]
   - SHA256:a1aba716abdbf9f2e3bc13d25734ff9fcc58a399698795ebc98f7cec76146d2e
   - SHA1:20e1b9792e678e5223d1387e4e5effaf5a4ca24f [weak]
   - MD5Sum:647502cff7f79ac8a4641b6519696b30 [weak]
  Release file created at: Wed, 03 May 2023 21:28:51 +0000

I’ve already submitted a support case #109808