Deploying VM from OVA and place it in vApp

Hey guys,

Recently I had a need to create a VMs inside a vApp, everything works fine if not using OVA.

Did anyone manage to create VMs from OVA directly in the vApp?

Here is a part of the tf code:

resource "vsphere_vapp_container" "vapp_container" {
  name                    = "vapp-01"
  parent_resource_pool_id = data.vsphere_compute_cluster.compute_cluster.resource_pool_id

resource "vsphere_virtual_machine" "vm" {
  name             = "foo"
  resource_pool_id =
  datastore_id     =
  num_cpus         = 1
  memory           = 1024
  guest_id         = "ubuntu64Guest"
  network_interface {
    network_id =
  disk {
    label = "disk0"
    size  = 20
  ovf_deploy {
    remote_ovf_url = data.vsphere_ovf_vm_template.ovfRemote.remote_ovf_url

However when I try to apply this, it returns:

Error: error while importing ovf/ova template, A specified parameter was not correct: pool

I tried to use multiple OVAs for a testing purposes, but it all resulted in the same error.

Any ideas how to do it properly?