Enable "Use ID instead of Email for Auth0 User ID" using terraform

I am trying to create auth0 connection for “Google Workspace” using terraform. But I don’t find any argument in terraform documentation to enable the “Use ID instead of Email for Auth0 User ID”. How can I enable it using terraform?

You have not indicated in which context this setting occurs, making it more challenging for anyone not very familiar with Auth0 to offer help.

Essentially, the process is:

  1. Go to the documentation for terraform-provider-auth0
  2. Figure out which Terraform resource relates to the context in which this setting is made
  3. Look for a relevant argument to set on the resource
  4. If none exist, terraform-provider-auth0 doesn’t support setting it - consider opening an issue with the provider.

Hi @maxb, I have explained the issue. Can you help me with this now ?

I have no further information to provide beyond my previous response as you haven’t clarified in which context within Auth0 the setting occurs.

It occurs inside - Authentication → Enterprise Connection → Google Workspace → “Name of workspace” → Settings → Auth0 User ID

That makes me guess it might relate to a Terraform auth0_connection resource?

That seems to have a user_id_attribute option - https://registry.terraform.io/providers/auth0/auth0/latest/docs/resources/connection#user_id_attribute

That has a string value rather than a boolean, but perhaps the Auth0 web UI is simplifying things and only presenting common cases, whilst the underlying API allows more flexibility?

This is all guesswork on my part, as far as Auth0 specifics are concerned, as my experience is all with other identity providers, but maybe it’s enough to give you a new avenue to investigate.