Error detecting host IP

Using windows 10
Packer version 1.7.2

“builders”: [
“type”: “vmware-vmx”,
“source_path”: “simpletest/ubuntu-1604-base.vmx”,
“ssh_username”: “blah”,
“ssh_password”: “blah”,
“output_directory”: “simpleoutput”,
“shutdown_command”: “shutdown -P now”

Tried numerous things on VMWARE networking , still get some kind of error like this, sometimes it says bridge sometimes it says host. But wont start VM.

hi i met this problem too

I fought through numerous issues, but in the end got it working.
I also went with ubuntu20 , which had other issues like how the initial preseed stuff works.

I think the main issue I had with connectivity was that the DHCP from the host system was giving a different IP when the box came back up after the first boot as older IPs came back or were released (from previous attempts).
The workaround I did was before I booted up for the first time , I changed the DHCP pool in VMWARE workstation to start at like 10 higher IPs that the last time. Then packer/VMWARE does not get confused. Then before EVERY new attempt I just kept upping it.