Fresh Nomad Install - Web UI Times Out

Hello,

I’m installing Nomad on Rocky Linux 9.3. I followed the tutorial on the developer website, but it doesn’t seem to have worked correctly. I did have to slightly modify the steps since the CentOS/RHEL steps still reference yum rather than dnf. Exact command sequence:

$ sudo dnf install -y dnf-plugins-core
$ sudo dnf config-manager --add-repo https://rpm.releases.hashicorp.com/RHEL/hashicorp.repo
$ sudo dnf -y install nomad

DNF reported a successful install of Nomad, and running the nomad command at the command line gets me the expected output, but attempting to navigate to the server host in a browser (nomad.company.local:4646/ui) returns a timeout error.

I attempted to open port 4646 using firewallcmd, but this had no effect.

$ sudo firewall-cmd --zone=public --add-port=4646/tcp --permanent

What do I need to do to continue to the web portal and configure Nomad?

I have identified my issue.

The Next Steps section in the documentation suggested the next step was to access the web ui. This is not entirely correct. The next step for me was instead found on the Create a Cluster page. I ran these two commands, in order.

export NOMAD_ADDR=http://nomad.company.local:4646
sudo nomad agent -dev \
  -bind 0.0.0.0 \
  -network-interface='{{ GetDefaultInterfaces | attr "name" }}'

Now when navigating to http://nomad.company.local:4646/ui I am able to access the portal successfully.