Unable to use the 'ui' stanza in nomad config

I’m using Nomad 1.2.2, and according to the documentation here: ui Stanza - Agent Configuration | Nomad by HashiCorp it should be possible to start a ui{…} block at the root of the nomad.hcl file, but no matter where I place the block (in root, in other blocks, etc.), nomad refuses to launch claiming that the ‘ui’ key is unrecognised.

Is the documentation out of date, or am I putting this in the wrong place?

Hi @John_Vidler! That feature actually hasn’t shipped yet; we’d expect it to be in Nomad 1.2.3. It shouldn’t be showing up in the documentation yet… but we’re in the middle of transitioning to “versioned docs” and I think we might have had a backporting mixup in the process of doing that. Stay tuned for Nomad 1.2.3!

1 Like

Right ok, that makes sense.

As a suggestion, can we include something like ‘Introduced in v1.2.3’ somewhere on the pages, so even when mistakes happen its clear that its not just user error?

@tgross

A “Yay!” for versioned docs, and a question about existing doc bugs … somewhere (I forgot which subsection), I noticed a beta 1.1 (or 1.1 beta) text around a parameter.

Should we just raise a PR for such discoveries?

For those who might find this at the moment, 1.2.3 also doesn’t appear to support this.

@John_Vidler looking at this issue, I see that it’s in the 1.2.4 milestone.

Yeah, Nomad 1.2.3 ended up being a security release, so everything that was in 1.2.3 ended up in 1.2.4 (to be released soon!)

Yes, thanks!

1 Like