[help] Issue with Nomad acl configuration in production environment

I am running a small nomad + consul cluster (should be production in the future) with 3 servers (running nomad server + client and consul server + client) on each server.

I bootstrap the nomad acl inside my userdata script like this:
nomad acl bootstrap >
SECRET_ID="$(sed -n -e ‘/Secret ID =/ s/.*= *//p’ )"
echo “$SECRET_ID” >
nomad status
nomad acl policy apply -description “Custom Policy” custom

after that the server will reboot once.
I am trying to get the nomad ui running and if i request the ui at http://:4646/ui i get an error response from following request: “/v1/acl/token/self” with message “rpc error: acl token lookup failed: missing secret id”.

I am new to nomad and don’t know how to fix this issue. The Nomad Documentation does not explain how to configure an nomad production environment. Maybe someone can help me with this problem :slight_smile:


Hi @oberpro,

Could you clarify how you are trying to access the Nomad UI? If you open your browser at https://<Nomad address>:4646 with ACLs enabled you should see a screen like this:

Which means you haven’t set the token in the UI yet. You can click in that blue ACL token link to set your token.

For more information on Nomad’s ACL system, check out this guide. We also have this one that talks about production deployments.

1 Like

Thanks for your response, Igfa29,

i finally see the nomad ui and i am able to authenticate with an acl token :smiley:
The issue is happening somewhere in my boundary http proxy, but this is another problem.

Thank you for your quick help!