Hyper-V Enhanced Session Mode Features Missing?

I’ve recently been working with Vagrant using the Hyper-V provider and running into a little bit of a gotcha. The base box that I created works perfectly fine, but when I create a VM using it in Vagrant, I’m not able to access connection settings. Specifically, when I connect to the base box VM from the Hyper-V Manager, I get the modal that allows me to configure local resources and select a screen resolution. When I connect to the VM created through Vagrant, I do not, and the “Edit Connection Settings” link on the Hyper-V Manager GUI does not display either. I tested this with a fairly simple Vagrantfile like so:

Vagrant.configure('2') do |config|
  config.vm.box = 'win-2019-hyperv-box-name'
  config.vm.provider 'hyperv'
  config.vm.network 'public_network', bridge: 'Default Switch'
  config.vm.guest = :windows
  config.vm.communicator = :winrm
  config.winrm.username = 'boxusername'
  config.winrm.password = 'boxpassword'
  config.vm.synced_folder '.', '/vagrant', disabled: false, mount_options: ['vers=3.0']
  config.vm.provider 'hyperv' do |h|
    h.enable_virtualization_extensions = true
    h.enable_enhanced_session_mode = true
  end
end

I’m a bit stumped here as to what’s going on. Using Vagrant 2.2.19 under Windows 10 21H2 (19044.1706), Hyper-V Manager version 10.0.19041.1.