Jaeger and Consul

Trying out tracing with Jaeger.

I’ve sidecar proxies running on a few services and setup ingress gateway. I added envoy static json for sending tracing to Jaeger. I can see envoy adding this in the config (exposed jaeger collector port through nodePort):
“cluster”: {
@type”: “type.googleapis.com/envoy.api.v2.Cluster”,
“name”: “zipkin”,
“type”: “STRICT_DNS”,
“connect_timeout”: “3s”,
“dns_lookup_family”: “V4_ONLY”,
“load_assignment”: {
“cluster_name”: “zipkin”,
“endpoints”: [
{
“lb_endpoints”: [
{
“endpoint”: {
“address”: {
“socket_address”: {
“address”: “x.x.x.x”,
“port_value”: 30914

Not using any agents on the applications side yet but when I make calls through ingress, I expected to see “proxy” showing up in Jaeger UI but there’s nothing. I can do a curl call, get successful response through the ingress and it does look like it’s a call going through envoy.
< HTTP/1.1 200 OK
< content-length: 31
< date: Sun, 09 Aug 2020 21:47:33 GMT
< x-envoy-upstream-service-time: 1
< server: envoy

Shouldn’t I expect to see something in Jaeger UI? Like I mentioned, not wanting to see any application specific spans (those do show up, by the way) but wanted to see proxy calls. Am I missing something?

Thanks for the help!

Hi @pvyaka01,

Thanks for posting! Have you reached out to the Jaeger community as well?

I do see that the consul-helm repo has an open issue on documenting open tracing with Jaeger, so I’d recommend watching that issue for more details.

Best,
Jono

haven’t posted in Jaeger community yet. Will do. Thanks!

No worries, @pvyaka01!

Also, someone pointed me to this repo where a demo was done with Jaeger. While I haven’t personally used it, I wanted to make sure others may be able to find it as well!

Best, Jono

Thank you. Followed that example but still no luck. I’ll keep checking. Also central proxy-defaults for envoy_extra_static_clusters_json and envoy_tracing_json doesn’t seem to work. I had to define within the service. It added something like this once I defined in the service…see hidden_envoy_deprecated_config…

“tracing”: {
“http”: {
“name”: “envoy.zipkin”,
"hidden_envoy_deprecated_config": {
“collector_endpoint”: “/api/v2/spans”,
“collector_cluster”: “jaeger_9411”
}
}
},

I’ll probably post as a bug in github

Hi @pvyaka01,

I saw the issue you opened on GitHub https://github.com/hashicorp/consul/issues/8503. I left a comment on a related issue, https://github.com/hashicorp/consul/issues/8519#issuecomment-692927140, explaining that it is currently expected behavior that ingresses will not initiate a trace.

However, this seems like a reasonable setting to expose as a configuration option. I’ve tagged 8519 as a feature request to track this request.