Kex_exchange_identification: banner line contains invalid characters

Hello again,

So I have boundary all set up in aws, everything seems to be working fine. I can authenticate as one of the default users (jim) but when I try to connect to one of my targets, I get the following error:

kex_exchange_identification: banner line contains invalid characters

Here is the command I entered, I tried to follow the deployment guide

boundary connect ssh --username Jim -target-id ttcp_

I seem to authenticate correctly, and the session shows up in the admin console as active. Also, we weren’t able to use Ubuntu instances, we used amazon linux2, we’ve had to change a lot of the install scripts so far.

Thanks for your help in advance,

Mind posting the results for ssh with the option “-vv”, so we can see the banner that’s being sent?

Hi Jim,
Which command do you mean? Do you mean
boundary connect ssh -w --username Jim -target-id ttcp_0XG1IVlVOs

That gives me this error:
flag provided but not defined: -w

sorry for the confusion. that’s “v” “v” without a space for “-vv”

Hi Jim,
vv is also not defined, I tried every combination of double v’s, with and without quotes, single and double dashes etc.

I’m so sorry. I had to go look at the code and figure out how to pass the “-vv” argument to the ssh command. I think this will work and give us some verbose debug info: boundary connect ssh -username jim -target-id ttcp_1234567890 – -vv

Hi Jim,

I think I figured it out. The BOUNDARY_TOKEN was blank. I went back through the tutorial and realized you need to export that token. I was following the connect guide in the reference architecture repo and it didn’t include that step of exporting to json etc. Now I’m receiving the “Connection closed by remote host” error, but I see there’s already a topic for that, so I’ll jump over there, thanks again!

Sorry I wasn’t much help and happy to hear you’re getting closer to making it work.

1 Like