No Vagrant file works for me

Hi all, my situation is as follows:

  • Fresh install of Ubuntu 18.04, without a GNU desktop. Pure command line!
  • I run the following commands:
    apt install virtualbox
    apt install virtualbox-ext-pack
    apt install vagrant

After this, I make a really simple Vagrant file. I have tried 2:

Vagrant.configure("2") do |config|
  config.vm.box = "ubuntu/xenial64"
end

and

Vagrant.configure("2") do |config|
  config.vm.box = "bento/ubuntu-18.04"
end

That’s it. Three lines but vagrant up still fails on both of them. I get this message:

There was an error while executing VBoxManage, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: [“import”, “/home/bas/.vagrant.d/boxes/ubuntu-VAGRANTSLASH-xenial64/20200430.0.0/virtua
box/box.ovf”, “–vsys”, “0”, “–vmname”, “ubuntu-xenial-16.04-cloudimg-20200430_1588265877834_92
91”, “–vsys”, “0”, “–unit”, “10”, “–disk”, “/root/VirtualBox VMs/ubuntu-xenial-16.04-cloudimg
20200430_1588265877834_92991/ubuntu-xenial-16.04-cloudimg.vmdk”, “–vsys”, “0”, “–unit”, “11”,
–disk", “/root/VirtualBox VMs/ubuntu-xenial-16.04-cloudimg-20200430_1588265877834_92991/ubuntu-
enial-16.04-cloudimg-configdrive.vmdk”]

Stderr: 0%…10%…20%…30%…40%…50%…60%…70%…80%…90%…100%
Interpreting /home/bas/.vagrant.d/boxes/ubuntu-VAGRANTSLASH-xenial64/20200430.0.0/virtualbox/box
ovf…
OK.
0%…
Progress state: VBOX_E_FILE_ERROR
VBoxManage: error: Appliance import failed
VBoxManage: error: Could not create the imported medium ‘/root/VirtualBox VMs/ubuntu-xenial-16.0
-cloudimg-20200430_1588265877834_92991/ubuntu-xenial-16.04-cloudimg.vmdk’.
VBoxManage: error: VMDK: Compressed image is corrupted ‘/home/bas/.vagrant.d/boxes/ubuntu-VAGRAN
SLASH-xenial64/20200430.0.0/virtualbox/ubuntu-xenial-16.04-cloudimg.vmdk’ (VERR_ZIP_CORRUPTED)
VBoxManage: error: Details: code VBOX_E_FILE_ERROR (0x80bb0004), component ApplianceWrap, interf
ce IAppliance
VBoxManage: error: Context: “RTEXITCODE handleImportAppliance(HandlerArg*)” at line 886 of file
BoxManageAppliance.cpp

What am I doing wrong?

Hey there! You should first check to make sure your home directory has enough space. It’s possible when Vagrant attempted to unpack the box, it couldn’t fully do so because of a lack of disk space. Otherwise, I would try removing both boxes fully and redownload them. Also make sure you are running the latest Vagrant too! If none of that works, please provide us with the full debug log from trying to bring up a box! Thanks.

Hi Brian, thanks for reaching out! I’m running these commands from a VirtualBox VM in Windows 10. The VM has been given 100GB. I’m currently using less than 10% of the total space, so I don’t think that is an issue. I have removed all available boxes, and ran these commands:

touch log.txt
vagrant up --debug &> log.txt

The up command still fails. I have included the log.txt file.

log.txt (86.2 KB)

Interesting. I was able to bring up that box just fine in my windows VM. Are you experiencing this error with every single Vagrant box? Have you tried others? Or maybe try a previous version of the box?? Also maybe give bento a try again, and try different platforms other than Ubuntu.

Also, the error you shared seems to be a VirtualBox error. It looks like you’re running version 5.2.34? That version is old at this point. If you can, uninstall that version and then download the latest version, which is 6.1.x I believe.