Vagrant up error while executing 'VBoxManage'

Running macOS 10.14.6, have tried with latest version of Vagrant and VirtualBox. After uninstalling both, I’ve installed Vagrant 2.2.2 and VirtualBox 6.0.24. Still getting this error when running vagrant up:

    Progress: 90%There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "/Users/ericgraham/.vagrant.d/boxes/hashicorp-VAGRANTSLASH-bionic64/1.0.282/virtualbox/box.ovf", "--vsys", "0", "--vmname", "ubuntu-18.04-amd64_1603901778979_91282", "--vsys", "0", "--unit", "11", "--disk", "/Volumes/BACKUP/ubuntu-18.04-amd64_1603901778979_91282/ubuntu-18.04-amd64-disk001.vmdk"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting /Users/ericgraham/.vagrant.d/boxes/hashicorp-VAGRANTSLASH-bionic64/1.0.282/virtualbox/box.ovf...
Progress state: NS_ERROR_INVALID_ARG
VBoxManage: error: Appliance import failed
VBoxManage: error: Code NS_ERROR_INVALID_ARG (0x80070057) - Invalid argument value (extended info not available)
VBoxManage: error: Context: "RTEXITCODE handleImportAppliance(HandlerArg *)" at line 957 of file VBoxManageAppliance.cpp
1 Like

There are a few reasons this can happen. The most common is a lack of free space on the local drive so the VM disks cannot be successfully copied resulting in this error. Another cause for this error can be if the copy sequence failed for some reason on the first try and directory still exists and an error is encountered attempting to unpack into the same location. First validate that you have ample free space available for making a copy of the local VM. Then run a destroy to ensure everything is clean for the current project (vagrant destroy -f) and then bring the guest up again (vagrant up).

1 Like

I’d read somewhere about the lack of space as being an issue, I originally had my vagrant directory on my local drive. The local drive has 200gb available, which I thought was enough. I decided to create a new directory on my external drive that has 9TB of available space. I ran the

vagrant destroy -f

==> default: VM not created. Moving on…
and then ran vagrant up.
Still get the same error.


Another cause could be that the original box that was downloaded and unpacked is some how corrupted. You can try doing a vagrant box remove hashicorp/bionic64 and then running a vagrant up again and letting it re-download the box to see if it resolves the error.

Just tried that and still getting the error. See attachment.

Screen Shot 2020-10-28 at 2.09.49 PM|690x398

Could you let me know what versions of Vagrant and Virtualbox are compatible with 10.14.6? Also, is 200gb sufficient space to run Vagrant?


I’m still having this issue. I’ve attached two logs I ran from debug. Please let me know what you find.


(Attachment vagrant2.log is missing)

(Attachment vagrant.log is missing)

Sorry here’s the log files saved as .txt files.


vagrant.txt (80.3 KB)

vagrant2.txt (2.31 KB)

With the error being generated by virtualbox being some what generic, I would suggest opening the virtualbox GUI directly and attempting to create a new VM with an ISO and determine if that succeeds correctly. It may be that there is an issue with your local virtualbox installation and running directly in the GUI mode may provide some clues as to the underlying issue.

I was able to figure out what was going on with this late yesterday. It was a problem with the ~/Library/Virtualbox folder. After deleting it, everything works.



I had a the same problem on Linux and removing ~/.config/VirtualBox fixed it for me

I have tried almost all suggestions here and none worked! I’d appreciate any other idea

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "02f2cb8c-0e1b-4035-85e8-7c11ff0d89b6", "--type", "headless"]

Stderr: VBoxManage: error: VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ConsoleWrap, interface IConsole

Which version of VBox are you using? Downgrading it to 6.1.16 worked for me, maybe some later versions would work too, haven’t tried it though.

I had same issue which i resolved by removing the corrupt box from


and then ran vagrant up where I had vagrantfile.

You are encountering this error because you do not have virtualization enabled in your bios settings. You will need to restart your machine, update the bios to enable virtualization (vt-x) and then boot your system.


I came across this page when using vagrant on macOs as a host.
I got error NS_ERROR_INVALID_ARG and E_ACCESSDENIED during my experiments. Tried deleting .vagrant.d completely and ~/Library/VirtualBox. None of it worked. Turned out I had to give full disk access to terminal and VirtualBox because I had a separate partition (at least I think it’s a partition, still not very familiar with macOs).

What I had to do is:
Apple logo menu → System Settings → Privacy and Security → In Privacy list select Full Disk Access → Enable Full Disk Access for Terminal and VirtualBox.

This got rid of my problems. In my case I also set vagrant home to a location on my partition for VMs.
Use text edit to edit ~/.bash_profile and add:
export VAGRANT_HOME=/your/path/to/vagrant/home

Which in my case was:
export VAGRANT_HOME=/Volumes/VM-Drive/VM/Vagrant/.vagrant.d
Instead of /Users/yourusername/.vagrant.d