Nomad plugin server error (use of closed network connection) And client: task “api” for alloc “X” failed: wait exit code 1

Hello :slight_smile: ,
I’m just learning, and I’m trying to start Consul-Nomad in docker container and they are starting. I managed to build and connect Consul-container and Nomad -container(nomadClient-container and nomadServer-container) (registration from Nomad to Consul). Until then everything went well, I mean there were a couple of difficulties, but I solved them. I then tried to start a nomad job inside my nomad-client container, the job is started but a few seconds later it goes to “pending” and then to “dead” and this is repeated endlessly until I disable the nomad-client-container.

I have looked at the logs and there were 2 errors.

This is the job-log on Nomad-UI:

I don’t know how to solve them :frowning: . I would be happy if you can help me :slight_smile:

Hi @Dja111!

Thanks for posting, and welcome to the forums! What was the resolution to the issue?

Thanks and have a good day!

@jsosulska, I don’t think this issue is resolved, isn’t it, @Dja111?

Hey @Dja111,

Could post some additional steps/information to reproduce this? For example nomad config + example of a job?

1 Like

Hey @Wolfsrudel - I found this thread due to is being “flagged” by the original poster. In the comments, they posted it was resolved, but I would like more information, so that others can understand :slight_smile:

The flags… Never noticed … Maybe I should do it. :grin:

1 Like