Nomad UI: Topology not showing CPU/MEM details

If I click the Job itself I can see the CPU/MEM utilization but if I click on topology I see hostnames and a blank box with M and C but nothing populated . Assuming this comes from telemetry here is what I have.

telemetry {
    publish_node_metrics = true
    publish_allocation_metrics = true
    prometheus_metrics = true
    collection_interval = "10s"
    disable_hostname = true

Hi @sammy676776,

The topology UI page doesn’t use the telemetry data and will use the /v1/allocations/ and /v1/nodes API endpoints. If you’re using ACL’s, you’ll need to ensure you have permissions that allow calling those.

If you can, I would suggest opening the browser developer tools, navigating to the “Network” tab and then reloading the topology page. This could show some useful information that might hint at potential problems.

jrasell and the Nomad team

Thanks @jrasell .I dont have ACL enabled for Nomad . I had enabled ACL for consul but disabled that too . Is ACL a mandatory requirement for this to work ?
I looked at the browser and all the following respond with 200 OK


Hi @sammy676776,

No, you don’t need ACLs enabled for this page to work.

To confirm, do you have running allocations on these clients? The page is suggesting there are none running on the clients, and thus they are empty.

jrasell and the Nomad team

@jrasell When the job runs i see the alloc but I see a grey box …no green bars …something is not right . I had changed the “data_dir” a few times in this cluster and not sure if that could lead to this but if there is a way to reset everything and start my jobs to make this show the metrics I am ready to do that .

Is it possible my jobs are not running long enough to show the allocations ?