Problem with vault

Hello there!

In advanced, I very appreciate your help. Right now, i’m using Vault for store secrets but two days ago I’m facing an issue with Vault because the pods are not initializing and also I have this error * core: barrier reports initialized but no seal configuration found. I can’t do anything because I got this error, I tried with: vault status, vault operator init, and a lot of other commands with the same result.

This one is my config:

disable_mlock = true
ui = true

listener "tcp" {
  tls_disable = 1
  address = "[::]:8200"
  cluster_address = "[::]:8201"
storage "gcs" {
  bucket = "vault-storage-prod"
  ha_enabled = "true"

service_registration "kubernetes" {}

seal "gcpckms" {
  project     = "core-delivery-platform-prod"
  region      = "us-east4"
  key_ring    = "vault-key-ring"
  crypto_key  = "vault-crypto-key"

telemetry {
 prometheus_retention_time = "30s",
 disable_hostname = true

Basically I’m using GCP GCS for storage and GCP KMS for seal. I already test if the pods have the capability to get KMS crypto keys and also the files from GCS.

Can you help me with that please? I recover the secrets but I need figure it out what happened for fix or make sure not happen again.

Thanks in advance!

The error message suggests that critical Vault data in the storage backend somehow went missing. If I understand the code correctly, it’s saying that core/seal-config is missing from the storage, which should be impossible once Vault has been initialized.