Provider: plugin failed to exit gracefully

We have an ADO repo setup to run terraform in pipeline, it works properly. When we copy repo to a workstation for local testing (lenovo laptop running win10, not an apple using M1 chip), terraform init works great (and is able to download providers without issue) however terraform plan, validate, or apply always fail.

We’ve tried on multiple workstations, we’ve deleted the .terraform directory and lock file and rerun init, we’ve tried different versions of the azurerm plugin (2.9.9, 3.7.0), different versions of terraform (1.1.5, 1.1.7, 1.2.0).

We’ve worked with our firewall/zscaler team to rule out any firewall blocks (shouldn’t be the case as we can query provider registry, and Terraform-Provider-Azurerm Versions | HashiCorp Releases). We saw a very similar sounding issue in relation to machines with trend AV, we do not have that but do have crowdstrike. We uninstalled crowdstrike altogether and that did not resolve the issue.

I’m running out of steam looking at wireshark, fiddler, tcpview, procmon, eventviewer, and everything else trying to figure out this issue. Need some help!

Error in console:
Error: Failed to load plugin schemas

│ Error while loading schemas for plugin components: Failed to obtain provider schema: Could not load the schema for
│ provider Terraform Registry failed to instantiate provider
│ “Terraform Registry” to obtain schema: Unrecognized remote plugin message:

│ This usually means that the plugin is either invalid or simply
│ needs to be recompiled to support the latest protocol…

snippet from TRACE log prior to fail
2022-05-26T12:14:37.144-0400 [TRACE] terraform.contextPlugins: Initializing provider “Terraform Registry” to read its schema
2022-05-26T12:14:37.144-0400 [DEBUG] created provider logger: level=trace
2022-05-26T12:14:37.144-0400 [INFO] provider: configuring client automatic mTLS
2022-05-26T12:14:37.153-0400 [DEBUG] provider: starting plugin: path=.terraform/providers/registry.terraform.io/hashicorp/azurerm/3.7.0/windows_amd64/terraform-provider-azurerm_v3.7.0_x5.exe args=[.terraform/providers/registry.terraform.io/hashicorp/azurerm/3.7.0/windows_amd64/terraform-provider-azurerm_v3.7.0_x5.exe]
2022-05-26T12:14:47.207-0400 [DEBUG] provider: plugin started: path=.terraform/providers/registry.terraform.io/hashicorp/azurerm/3.7.0/windows_amd64/terraform-provider-azurerm_v3.7.0_x5.exe pid=5616
2022-05-26T12:14:47.207-0400 [DEBUG] provider: waiting for RPC address: path=.terraform/providers/registry.terraform.io/hashicorp/azurerm/3.7.0/windows_amd64/terraform-provider-azurerm_v3.7.0_x5.exe
2022-05-26T12:14:47.207-0400 [TRACE] statemgr.Filesystem: removing lock metadata file .terraform.tfstate.lock.info
2022-05-26T12:14:47.207-0400 [TRACE] statemgr.Filesystem: unlocked by closing terraform.tfstate
2022-05-26T12:14:47.214-0400 [WARN] provider: plugin failed to exit gracefully
2022-05-26T12:14:47.222-0400 [DEBUG] provider: plugin process exited: path=.terraform/providers/registry.terraform.io/hashicorp/azurerm/3.7.0/windows_amd64/terraform-provider-azurerm_v3.7.0_x5.exe pid=5616 error="exit status 1"