Qemu builder + centos questions

does anyone have any advice on how to get packer to successfully build qcow2 images via qemu?

so far, i’ve tried on a physical centos 7 host with qemu-kvm installed and in a vagrant vm locally (vagrant, virtual box, os x). both seem to time out trying to connect via ssh, even with a simple config and kickstart. i haven’t been able to verify whether packer actually kicks off the install, however. attempting to connect to the vnc port just fails, even though there’s no password set.

here’s a simple example of what i’m trying. i cobbled together the kickstart from various places. the kickstart itself worked with a manual install i kicked off via virtualbox.

the only seemingly relevant log details are that ssh retries until the timeout duration expires:

2022/03/21 00:24:58 packer-builder-qemu plugin: [DEBUG] SSH handshake err: ssh: handshake failed: read tcp> read: connection reset by peer
2022/03/21 00:25:05 packer-builder-qemu plugin: [INFO] Attempting SSH connection to
2022/03/21 00:25:05 packer-builder-qemu plugin: [DEBUG] reconnecting to TCP connection for SSH
2022/03/21 00:25:05 packer-builder-qemu plugin:

which is really not much help in debugging this.

does anyone have an actual working example handy or any tips to get this going? thanks in advance.