Saving a generated plan is currently not supported

Hi all,

I just started getting the following error yesterday - it seems the Terraform backend no longer supports saving generated plans. This was working for the last month, can someone please advise if this is a bug? I can’t see anything in the plan or remote docs regarding this limitation…

Steps to reproduce:

$ terraform workspace new quicktest5

Created and switched to workspace "quicktest5"!

You're now on a new, empty workspace. Workspaces isolate their state,
so if you run "terraform plan" Terraform will not see any existing state
for this configuration.

$ terraform plan -out=plan -input=false

Error: Saving a generated plan is currently not supported

The "remote" backend does not support saving the generated execution plan
locally at this time.

$ # then run -> terraform apply -input=false plan

Can also getting this error. Can confirm this workflow was functional last two weeks back.

terraform workspace create new_env
terraform workspace select new_env
terraform init
terraform plan --out ./out.plan -var-file=.env

Error: Saving a generated plan is currently not supported!

The "remote" backend does not support saving the generated execution
plan locally at this time.

Never mind. I found it. A Recent update to Terraform Ent. now includes some additional settings. the setting `` needs to be set to local for workspaces created after the Ent. update.

image

2 Likes

What the actual… Why would a new option break all my pipelines!!! Thank you for sharing how you solved it. Much appreciated.

Any updates on this, could be nice not having to change each and every workspace.

For anyone looking to automate this workaround you can call the API:

curl --request PATCH \
--header "Content-Type: application/vnd.api+json"
--data '{"data":{"attributes":{"operations":false}}}' \
--url https://app.terraform.io/api/v2/organizations/<your workspace>/workspaces/<your repo>
1 Like

Agreed, a default workspace execution for the organization would make it less painful for all of us…

As an additional workaround until we can get this feature implemented, we’ve added the configuration to the TFE provider as part of version 0.11.1. If the API route is a bit much, you can also configure it via Terraform.

In the meantime, please upvote this comment on Github. That way, we can better track its priority.