Self-hosted worker error: upstream is not a licensed Boundary controller or worker”

I am facing issue with KMS based ingress worker with the below error:
“checking boundary controller connection: worker.checkhcpconnection: upstream is not a licensed Boundary controller or worker”

I have already Enterprise boundary controller version 0.15.0+ent running on different vm and also boundary worker has same version of binary without specifying license details in KMS Ingress worker config file.

Anyone can help with this.

Would you mind sharing the worker and controller logs from the time of the error (with any sensitive information redacted)?

sure, please see the attached boundary controller and ingress worker config file as both are self-hosted on different VM.
On the side note, we are using trial enterprise licence from hashicorp and it is 0.15.0+ent binary version, I’m using on both worker and controller.
I am not sure if this is related to trial licence given by hashicorp or the way this trial licence is generated with some additional flags?

Sample_BoundaryController_config.txt (1.0 KB)
Sample_BoundaryIngressWorker_config.txt (479 Bytes)

Apologies, could you re-create the error and attach the logs from the controller and worker instead of their config files? The messages there should help me get a better idea what’s causing the issue. Thanks for including the config files!

A trial license should still allow you to set up a controller and ingress worker, so I don’t think that’s the issue.

here go! please see the attached ingress worker log, I have removed unnecessary common info such id, version, spec version and left only relevant messages.

awaiting your response
Ingress-worker-log.txt (1.8 KB)

@irena.rindos , any suggestion or views on the logs of the worker, Thanks

Would you mind sending complete logs for both the controller and worker, leaving in the version and other information that isn’t sensitive to your deployment? Other messages may be relevant to determine what state the worker and controller are in.

Hi @irena.rindos , when I restart the kms worker then looking at boundary controller server logs, there is message as below:

{“id”:“MQFCaz8kNu”,“source”:“https://hashicorp…”,“data”:{msg":did not find worker id in state map"}}

Not sure what does it mean by did not find worker id in state map?

Worker ids are assigned by the controller, so a worker does not know its own ID until after its first successful status to the controller. From that point onwards, a worker’s id is included in its connection info sent upstream.

This means that message is expected the first time the worker connects to an upstream, since it doesn’t know its worker id yet and cannot include it.

So do you know how to fix this, I have tried authenticate and registering worker via PKI method still I get the same error?

Any solution to resolve this.