Setting proxy defaults on secondary consul cluster


I am setting up federation between two clusters. Both clusters are in the private and different networks. I exposed mesh gateways via public load balancers. I got an error in the mesh gateway of secondary cluster, but I got rid from an error by adding the ProxyDefaults in the primary cluster. But still, consul members --wan is not returning the other consul cluster. That means mesh gateways couldn’t be able to communicate with each other.

Do I also need to add ProxyDefaults for the secondary cluster as well? If setting ProxyDefaults in the secondary cluster also doesn’t work, then what else would be the problems?

P.S: The platform is GKE

Hi @dani2819, were you able to resolve this issue? If not, could you share the logs from the Consul servers in the sceondary data center, as well as the logs from the mesh gateway?