Some secrets get deleted after upgrading vault to 1.15.1 from 1.10.0

Hi Team

I recently upgraded my vault from 1.10.0 to 1.15.1. It went well and later figured out that the latest secrets we added got deleted. I also found both kv and kv/-v2 were shown as version 2 in the UI as well as CLI.


When tried searching forums, I found this [1.15.0] kv secrets not showing in the UI · Issue #23463 · hashicorp/vault · GitHub. I have tried to do as per this comment but I was unable to do it.

user@vault:~$ vault read sys/mounts/kv
Key                        Value
---                        -----
accessor                   kv_1
config                     map[default_lease_ttl:0 force_no_cache:false max_lease_ttl:0]
deprecation_status         supported
description                n/a
external_entropy_access    false
local                      false
options                    map[version:2]
plugin_version             n/a
running_plugin_version     v0.16.1+builtin
running_sha256             n/a
seal_wrap                  false
type                       kv
uuid                       f8c6b89b

When I tried to execute this below command to tune back to version 1. I got this error:

user@vault:~$ vault secrets tune -options="version=1" kv-v2
Error tuning secrets engine kv-v2/: Error making API request.

Code: 400. Errors:

* cannot downgrade mount from version 2

Now how to resolve this issue and retrieve my secrets?

Thank you In advance!!