Terraform doesn't react on plan/destroy/apply commands after i once stopped destroying in the middle of the process

Hi. Recently i was destroying my deployment resources on AWS via python-terraform wrapper. But, i intentionally interrupted it in half path . After it, when i again wanted to destroy my deployment - terraform said me, that i have “locked process with some uuid”. I tried to kill that proccess with force-unlock command, but it didn’t help. Moreover, now i have very strange situation… When i want to activate commands like : destroy, plan, apply terraform don’t write me any info in console (console don’t show any signs, that terraform are running - empty line, which lasts forever).
I tried to delete terraform, all state files, lock files, backup files, providers - but it does help nothing. Also, tried to create another project (i had a believe, that new project - would give terraform a new life), but it doesn’t help.
Commands like terraform init, validate, refresh, providers … work well
All this situations reprodeuce in the same way with simple cli, which also doesn’t want to react on specified commands before.

how can i force delete/dawloand or refresh again terraform, to get terraform “OOTB” ? or, may be some ideas, how can i detect the problem, which made me stuck ?

os: linux
terrafrom: v0.14.9
python-terraform: 0.10.1
python: 3.7
terraform-provider-aws_v3.35.0_x5 / linux amd64

Hi @Bushmeniov,

Do you have a backend block in your configuration to activate remote state storage? If so, it’d be helpful if you could share that configuration block (being careful to remove any senitive information that might be in it) because the locking behavior you saw here is implemented by the configured backend and so the steps to unlock will vary depending on which backend you are using.